Tasks may experience longer wait times than usual
Resolved·Degraded performance

Task wait times are back to normal.

Mon, Sep 22, 2025, 11:26 PM
(5 days ago)
·
Affected components
Updates

Resolved

Task wait times are back to normal.

Mon, Sep 22, 2025, 11:26 PM

Monitoring

We have fixed the underlying issue and processing the backlog of tasks. Wait times should be back to normal.

Mon, Sep 22, 2025, 11:24 PM

Identified

Tasks that were enqueued between 1:49PM PT to 3:19PM PT are currently waiting to be scheduled. Tasks enqueued since are being executed but may experience longer than usual wait times.

Mon, Sep 22, 2025, 10:40 PM(44 minutes earlier)