Resolved
We have deployed a fix for this issue.
Investigating
We have resolved the issue.
Investigating
Some users are experiencing errors on log in as well as account creation. We have identified the root cause.
Investigating
A minor bug where some users are seeing an issue creating an account.