Resolved
We have expanded our load balancer resources and added targeted alerts to prevent this from happening again.
Identified
We've identified the issue and are expanding our load balancer resources.
Investigating
Some customers' HTTP requests are receiving a 503 response code.