Resolved
Tasks from the 11:45 am to 12:45 pm are finishing now. Latencies have dropped back down.
Identified
Incident is mitigated for new task api requests.
A small number of API requests between 11:45 am to 12:45 pm are stuck in a queued state, which will be resolved in the next hour.
Identified
Seeing elevated request times due to a spike in traffic, bringing up more capacity to reduce the effect. Expected to resolve in ~20 min.